Download

Baixe o Bootstrap e obtenha o CSS e JavaScript compilado, além do código fonte. Também, você pode incluir o framework no seu gerenciador de pacotes predileto como npm, RubyGems, etc.

CSS e JS compilado

Baixe o código compilado e pronto para uso do Bootstrap v4.1.0 para, facilmente, começar seu projeto. O download inclui:

Este download não inclui documentação, códigos fontes ou qualquer dependências JavaScripts (jQuery ou Popper.js).

Baixar

Arquivos fontes

Compile o Bootstrap com suas próprias ferramentas, baixando nosso Sass, JavaScript e arquivos da documentação. Esta opção requer algumas ferramentas adicionais:

  • Compilador Sass (Libsass ou Ruby Sass) para compilar seu CSS;
  • Autoprefixer para usar prefixos CSS.

Ferramentas de build são usadas para desenvolver o Bootstrap e sua documentação, mas pode ser que sejam desncessárias para você.

Baixar fonte

BootstrapCDN

Evite o download, usando a BootstrapCDN para ter uma versão em cache dos CSS e JS compilados, em seu porjeto.

<link rel="stylesheet" href="https://stackpath.bootstrapcdn.com/bootstrap/4.1.0/css/bootstrap.min.css" integrity="sha384-9gVQ4dYFwwWSjIDZnLEWnxCjeSWFphJiwGPXr1jddIhOegiu1FwO5qRGvFXOdJZ4" crossorigin="anonymous">
<script src="https://stackpath.bootstrapcdn.com/bootstrap/4.1.0/js/bootstrap.min.js" integrity="sha384-uefMccjFJAIv6A+rW+L4AHf99KvxDjWSu1z9VI8SKNVmz4sk7buKt/6v9KI65qnm" crossorigin="anonymous"></script>

Se você está usando nosso JavaScript compilado, não esqueça de incluir as versões em CDN do jQuery e Popper.js, antes dele.

<script src="https://code.jquery.com/jquery-3.3.1.slim.min.js" integrity="sha384-q8i/X+965DzO0rT7abK41JStQIAqVgRVzpbzo5smXKp4YfRvH+8abtTE1Pi6jizo" crossorigin="anonymous"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.3/umd/popper.min.js" integrity="sha384-ZMP7rVo3mIykV+2+9J3UJ46jBk0WLaUAdn689aCwoqbBJiSnjAK/l8WvCWPIPm49" crossorigin="anonymous"></script>

Gerenciador de pacotes

Use o código fonte Bootstrap em qualquer projeto, com ajuda dos mais populares gerenciadores de pacotes. Não importa o gerenciador de pacotes, o Bootstrap vai precisar de um compilador Sass e do Autoprefixer, para se ter uma configuração compatível com nossa versão compilada oficial.

npm

Instale o Bootstrap em seus apps Node.js com o pacote npm:

npm install bootstrap

require('bootstrap') vai carregar todos os plugins jQuery no objeto jQuery. O próprio módulo bootstrap não exporta nada. Você pode, manualmente, carregar os plugins jQuery Bootstrap individualmente, carregando os arquivos /js/*.js dentro do diretório principal dos pacotes.

O package.json possui alguns metadados, nas seguintes chaves:

  • sass - caminho para o principal arquivo Sass Bootstrap;
  • style - caminho para o CSS não minificado Bootstrap, o qual foi pré-compilado usando configurações padrões (sem customização).

RubyGems

Instale o Bootstrap em seus apps Ruby, usando o Bundler (recomendado) e RubyGems, adicionando a seguinte linha ao seu Gemfile:

gem 'bootstrap', '~> 4.1.0'

Alternativamente, se você não está usando o Bundler, pode instalar a gem executando este comando:

gem install bootstrap -v 4.1.0

Veja o README da gem, para mais detalhes.

Composer

Você também pode instalar e gerenciar o Sass e JavaScript do Bootstrap, usando o Composer:

composer require twbs/bootstrap:4.1.0

NuGet

Se você desenvolve em .NET, também pode instalar e gerenciar CSS, Sass e Javascript, usando NuGet:

Install-Package bootstrap
Install-Package bootstrap.sass